How to Capture Network Traffic Logs for Kaltura Support?

What is a Web Debugging Tool?

A web debugging tool is a web proxy (HTTP Proxy / HTTP Monitor) that runs on your own computer. Your web browser (or any other Internet application) is configured to access the Internet through the proxy, and this proxy is then able to record and display the network traffic data coming in and out of your computer.

Kaltura recommends using Fiddler for Windows, and Charles Proxy for Mac.

When Should You Capture Traffic Logs?

Since traffic logs record communication from and to Kaltura, they can help identify the real cause behind issues that end users see in the front end.
Traffic logs are especially useful for Kaltura Support to investigate issues that are specific to the user’s network or that are not reproducible.

Fiddler

How to capture web traffic using fiddler

  1. Download 'Fiddler' software from http://www.fiddler2.com/Fiddler2/version.asp
  2. Open the installer file and follow the installation instructions.
  3. Once installed, open the software and make sure it is Capturing traffic:
    Firefox may be configured to use its own Proxy settings. If you see no traffic recorded, please see http://www.fiddlertool.com/fiddler/help/hookup.asp#Q-NonIE.

    To capture traffic that is transferred through HTTPs / SSL use the followings instructions:
  4. Go to Fiddler open Tools->Fiddler options.
    1. In the Fiddler options menu, select the HTTPS tab and mark the "capture HTTPS CONNECTs and Decrypt HTTPS traffic" options.
  5. Clear the browser cache.
  6. Recreate the issue while Fiddler is running and Capturing.
  7. After capturing the event please save it as a .saz file.

 * Additional assistance on how to use the software can be found here: http://www.fiddlertool.com/fiddler/help/ui.asp  

Charles Proxy

How to Capture Web Traffic Using Charles Proxy

  1. Download the software 'Charles Proxy' from http://www.charlesproxy.com/download/
  2. Install the software and run it.
  3. When the software opens, in the upper left corner of the window the red dot "recording" should be highlighted – if it isn’t, click the button to “Start/Stop recording".


    If you need to capture HTTP / SSL traffic, see http://www.charlesproxy.com/documentation/proxying/ssl-proxying/
  4. Clear the browser cache.
  5. Recreate the issue you are experiencing while Charles is running.
  6. Once done, click on File->Save As, and select a unique name.

    * additional information about 'Charles' can be found @ http://www.charlesproxy.com/documentation/

FireBug (for Firefox only)

How to Capture Network Traffic Using Firebug?

  1. Download and install Firebug: (in FireFox only)
    1. From addons.mozilla.org (AMO( - Tools>Addons>Get Addons>Search["firebug"]
    2. From Firebug's releases page - https://getfirebug.com/releases/
  2. An additional extension is needed for exporting all network Traffic – 'NetExport'. Download the latest stable version from https://getfirebug.com/releases/netexport/.
  3. Restart Firefox.
    If you need to capture traffic that is transferred through HTTPs / SSL use the followings instructions:
    1. Go to Fiddler open Tools->Fiddler options.
    2. In the Fiddler options menu, select the HTTPS tab and mark the "capture HTTPS CONNECTs and Decrypt HTTPS traffic" options.
  4. To activate 'Firebug',  click 'F12',  or  the FireBug icon located at the top panel.

    A console will open at the bottom of the screen.
  5. Click on 'Net' > 'All'  to capture all web traffic. You should see HTTP traffic being logged at the console.
  6. Recreate the issue and export it as 'HAR' file. Send us the .har file.

* Additional information about Firebug can be found @ https://getfirebug.com/wiki/index.php

Google Chrome Dev Console

How to capture web traffic using Chrome Dev Console

  1. Push F12 on your keyboard (or right click on the page and select ‘Inspect Element’). The console appears on the bottom of the screen.


  2. On the console, select the network tab.


  3. Clear the browser cache.
  4. Recreate the issue while the console is open. You will see the HTTP traffic being logged.
  5. Right click on any of the lines and select ‘Save all as HAR’.
  6. Send us the .har file.

* Additional information about 'Chrome web debugger' can be found @ https://developers.google.com/chrome-developer-tools/docs/network

 

  

In This Article