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Capture troubleshooting guide
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{ 222 This article is designated for all users.

About

This guide covers common Capture issues and how to fix them. If you're having trouble
uploading, recording, or launching the app, start here.

A

If you're having trouble downloading Kaltura Capture, the issue may be related to
your organization's IT settings. Some networks block software downloads or
installations. If the download doesn't start or fails, try contacting your IT department
to make sure the app isn't being blocked by your system’s security settings or
firewall.

Access the recordings folder

Some of the troubleshooting steps in this guide ask you to open the folder where
Capture stores your recordings. You have two options for this:

Windows

Option A

1. Open File Explorer (click the folder icon in your taskbar).

2. In the left-hand sidebar, click (replace 'username’ with your Windows user
name): This PC > Local Disk (C:) > Users > username > AppData > Local >
Kaltura > Capture > Recordings

If you don’t see the AppData folder, you may need to enable hidden files: click
View > Show > Hidden items in the File Explorer toolbar.

Option B

1. Open File Explorer (click the folder icon in your taskbar).

2. Copy this path (replace 'username'’ with your Windows user name): C:\Users\user
name\AppData\Local\Kaltura\Capture\Recordings
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3. Paste it into the address bar at the top and press enter.

o
In version 4.2.141 and above, you can also find the folder path under the app’s
Settings tab.

Mac

If you're using a Mac, follow these steps to find your Capture recordings.

Option A

1. Open Finder (the blue-and-white face icon in your Dock).

2. Click Go (in the top menu bar), then select Go to Folder.

3. Paste this path (replace 'username' with your Mac user name): /Users/user
name/Library/Preferences/Kaltura/Capture/Recordings

4. Click Go.

Option B

1. Open Finder (the blue-and-white face icon in your Dock).

2. Click Macintosh HD > Users > [your username].

3. Hold the Option key, then click the Go menu and choose Library.
4. Then go to Preferences > Kaltura > Capture > Recordings.

Access the Settings folder

Some of the troubleshooting steps in this guide ask you to open the settings folder. This
is where advanced configuration files are stored (used for fixes like disabling auto-
upload or hardware acceleration).

Windows

1. Open File Explorer and paste this path into the address bar (replace '‘username' with
your Windows user name): C:\Users\user
name\AppData\Local\Kaltura\Capture\Settings

2. Press enter.

Mac

1. Open Finder > Go > Go to Folder, then paste in this path (replace 'username'
with your Mac user name): /Users/user
name/Library/Preferences/Kaltura/Capture/Settings.
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2. Click Go.

Uploading issues

Green screen appears after upload

If your recording looks fine on your computer but turns green after uploading, try this:

Force Capture to use the CPU encoder:

1. Right-click on your desktop and select Display settings.

N

Scroll down and click Graphics.
3. Under “Choose an app to set preference,” select Desktop app.
4. Click Browse. When File Explorer opens, do the following:

e Double-click Local Disk (C:).
e Go to: Program Files > Kaltura > Capture.
e Select KalturaCapture.exe and click Add.

5. Once it's added, click Options.

6. Click Save.

Disable hardware optimizations in config file:

1. Open the Settings folder (see note at the top of this guide if you're not sure how).
2. Open the file called localSettings.json.

3. Under the captureEngine section, add: "hwOptimisations": false

4. Save and restart the app.

¥s

"captureEngine™: {
"hwOptimisations"”: false,
"loglevel™: "info™,
"logTruncate”: false,
"logFileMax5Size": 18485768,
"logMaxFileCount™: 1@,
"maxQueuedSamplesCount”: 18060,
"maxQueuedVideocSamplesCount™: 3@,
"gpoplength": 2880,
“deviceBlackList™: [

"Blackmagic”

1,

Upload stuck in 'Pending’
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If your recording is stuck in 'Pending' and won’t upload, you can reset it so Capture
tries again. Each recording comes with a .json file that contains info about the upload
status. Editing this file the right way will allow the app to retry the upload.

Try this:

1. Go to the Recordings > completed folder (see note at the top of the guide if
you're not sure how).

2. Find the .json file that matches the stuck video (the name and time should be
similar), and open it using a text editor like Notepad (right-click the file and choose
Open with > Notepad).

3. Look for the line that starts with "uploadStatus" and delete everything below it, but
don't delete the final closing bracket } at the bottom of the file.

4. Replace the line with "uploadStatus": "auto".

1600355639663 - Notepad
File Edit Format View Help

{
"appToken": "2510a5fa63b6092e334bd0e90cd4908b",
"appTokenId": "1_gixiy5rd",
“durationSec": 26.038,
"hashType": "SHA256",
"isAudioOnly": false,
"ownerId": "sharvari.lakhani@kaltura.com",
"partnerId": 3024301,
"primaryMediaFile": "C:\\Users\\SharvarilL\\AppData\\Local\\Kaltura\\Capture\\Recordings\\\\C87C9F19-1ACC-46EB-8727-5BFOA36
"recordingStartTime": 1600355594889,
"secondaryMediaFile": "C:\\Users\\SharvarilL\\AppData\\Local\\Kaltura\\Capture\\Recordings\\\\38F3B911-E26F-4C1F-81E9-82D32
"serviceUrl": "https://www.kaltura.com",
"summary": "Kaltura Capture recording - September 17th 2020, 11:13:14 am",
"tags": ""
"uploadStatus": "uploaded" "uploadstatus": "auto"
"primaryEntryId”: "1_j2d947m4",
"secondaryEntryId": "1_vdépcgso",
"uploadTokens": {
"1_vd6épcgso”: "1_ee5d9fla97fcb25acf5571bbf29fbobd",
"1_j2d947m4": "1_b9bc80afdf9cc55ebad6doveea7det6e”
1,
"progress": {
"C:\\Users\\SharvarilL\\AppData\\Local\\Kaltura\\Capture\\Recordings\\\\38F3B911-E26F-4C1F-81E9-82D326A6D2F7-.mp4": {
"chunksUploaded": 1,
"totalNumOfChunks": 1

Iy

?)
"C:\\llserc\\Sharvaril \\AnnData\\l acal\\Kaltura\\Canture\\Recordines\\\\CR7CQF19-1ACC-4AFR-R727-5RFAAIARIRNAF- .mnd": {

5. Save the file.
Move both the video file and the edited .json file back to this folder (replace
'username' with your Windows user name): C:\Users\user
name\AppData\Local\Kaltura\Capture\Recordings.

How to move the files:

a. Select the edited .json file and the matching video file (usually .mp4)
b. Right-click and choose Cut.
c. Go back to the main Recordings folder (see instructions at the top of this guide)

d. Right-click in the folder and choose Paste.
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7. Open Capture. It should now detect the video and try uploading it again.

Upload stuck in 'Cancelling’

If you tried to cancel an upload and now the recording is stuck in 'Cancelling’, you can
recover it by editing its settings file. Each recording includes a .json file that stores info
about its upload status. By manually editing this file, you can reset the upload and
bring back the Upload button in the Kaltura Capture app.

Try this:

1. Open the Recordings folder (see note at the top of the guide if you're not sure
how).

2. Find the .json file that matches your recording and and open it using a text editor
like Notepad (right-click the file and choose Open with > Notepad).

3. Look for the line that starts with "uploadStatus" and delete everything below it, but

don't delete the final closing bracket } at the bottom of the file.
4. Replace the line with "uploadStatus": "manual” (this tells the app to allow manual

upload).

711600355639663 - Notepad
File Edit Format View Help

{
"appToken": "2510a5fa63b6092e334bd0e90cd4908b",
"appTokenId": "1_gixiy5rd",
"durationSec": 26.038,
"hashType": "SHA256",
"isAudioOnly": false,
"ownerId": "sharvari.lakhani@kaltura.com",
"partnerId": 3024301,
"primaryMediaFile": "C:\\Users\\SharvarilL\\AppData\\Local\\Kaltura\\Capture\\Recordings\\\\C87C9F19-1ACC-46EB-8727-5BFOA36
"recordingStartTime": 1600355594889,
"secondaryMediaFile": "C:\\Users\\SharvarilL\\AppData\\Local\\Kaltura\\Capture\\Recordings\\\\38F3B911-E26F-4C1F-81E9-82D32

"serviceUrl": "https://www.kaltura.com",
"summary": "Kaltura Capture recording - September 17th 2020, 11:13:14 am",
gt "

"uploadStatus”: nuploadedn’Et::>”uMOadSmtu§E”manan
“primaryEntryId™: "1_j2d947m4",
"secondaryEntryId": "1_vdépcgso",
"uploadTokens": {
"1_vdépcgso”: "1_ee5d9flad97fcb25acf5571bbf29fbobd",
"1_j2d947m4": "1_b9bc80afdfIcc55ebad6do@eea74eb6e”

B
"progress": {
"C:\\Users\\SharvarilL\\AppData\\Local\\Kaltura\\Capture\\Recordings\\\\38F3B911-E26F-4C1F-81E9-82D326A6D2F7-.mp4": {
"chunksUploaded": 1,
"totalNumOfChunks": 1

3

"C:\\llser<s\\Sharvaril \\AnnData\\l acal\\Kaltura\\Canture\\Recarding<\\\\CR7C9F19-1ACC-4AFR-R727-5RFAAIRIRNAF-.mnd": {

5. Save the file.
6. Open Capture. You should now see the Upload button appear next to the recording,
allowing you to re-upload it.

Downloading and locating recordings

Download desktop view and presenter view

Each Capture recording creates two entries: Desktop (Primary) and Camera
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(Secondary).

1. Go to My Media in your video portal.
2. Search for the entry ID in the search field.

Home ‘Web Training Pleased to Meet You +  What is MediaSpace? Creating the Perfect Video All Channels Styling Options

Update Profile

Unregister

My Media
/ My Media
Q a My Playlists
My Channels
S Sort By: Crea ate - < n —_— - MyHistory
Filters > Sort By: Creation Date - Descending v — NS v
My Rooms
Watch Later
[m]

® Logout

This will bring you to both entries of the Capture recording, the ‘Desktop View' and
the 'Presenter’ view.

Home Web Training PleasedtoMeetYou v  Whatis MediaSpace? Creating the Perfect Video All Channels Styling Options Contact us Kaltura Learning

My Media
O e %
Filters > Search In: All Fields v  Sort By: Relevance « = = = ACTIONS ~
]
O Kaltura Capture Test
Show More
Private
0 Kaltura Capture Test
Show More

Private

3. Open one of the entries, then click the Downloads tab.
4. Next to Available Formats select Source.
5. Click Save then click Go To Media.
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Details Publish Options Collaboration Thumbnailsl Downloads raptions Attachments Timeline Replace Media Registration

Available Formats: | Source I

| Go To Media
4.

6. Use the Download option to download the file.

Kaltura Capture Test ®0o »0 ®0

From Alex De Los Santos on June 28th, 2021

Details || Download |} Share Q ACTIONS ~

Name Size Actions ‘/
&

Source (210 Mb)

Repeat for the second entry.

Recover both streams locally

Normally, Capture uploads your screen and camera together as one video. But if you
need to work with them separately, like uploading to another platform or editing them
manually, you can grab the original video files from your computer.

These files are only available on the computer where the recording was originally
made. If you're on a different device, they won’t appear in the folder.
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Try this:

1. Open the Recordings folder (see note at the top of the guide if you're not sure
how).
Look for two video files ending in .mp4. These are your original screen and camera
recordings. Their names will look similar and have the same timestamp.
Right-click each file and choose Copy.

3. Open the folder where you want to save them, for example, your Desktop or
Documents.
Inside that folder, right-click on an empty space and choose Paste.

5. From there, you can rename, edit, or upload the files wherever you need.

tra\\AppDatat\Local\\Kaltura\\Caprure\\Recordingsh \\\B450581D-6633 ~4EAD-B1C1-167EEBE4D2EE- . mpd ",
Mitra\\AppData\\Local\\Kaltura\\Capture\\Recordings\\\ \FA7BS BFD-EFEE-4545-9E21 -FOEFCCBE54E0 - mp4d™

- February 23rd 2021, 12:27:42 pn",

1_55017£c447615¢808cb3407e009663577,
1_07d4d718065533cébbiefe3Tebbed240"™

"1_bwy11036
"1_tous:

Installation and startup issues

Capture download won't start

Problem: You click the Download button for Capture, but instead of downloading the
file, the page just reloads - nothing happens.

Fix: This is usually a configuration issue. Contact Kaltura Support.
Capture won't install

If Capture won’t install or open, try a clean reinstall.

Try this:

1. First back up your recordings so you don’t lose them during reinstallation:

e Open the Recordings folder (see note at the top of the guide if you're not sure
how).

e Find the video files ending in .mp4 - these are your recordings.

[ ]

Select the ones you want to keep, right-click, and choose Copy.

Go to a safe location like your Desktop or Documents, then right-click and choose
Paste.

2. Next, uninstall the current version:
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Click the Start menu and go to Settings > Apps > Installed apps.

Search for Kaltura Capture in the list.
Click the three dots next to it and select Uninstall.

Confirm when prompted.
3. Delete leftover folders: Bin, Settings, setup from the Capture folder.
4. Reboot your computer.

5. Download the latest version from the Release Notes and reinstall using the
Installation Guide.

Configuration tips

Manually change Capture settings

Some advanced settings can only be changed by editing the app’s configuration file.
Try this:

1. Open the Settings folder (see note at the top of this guide if you’'re not sure how).

2. Open the file called localSettings.json using a text editor like Notepad (right-click the
file and choose Open with > Notepad).

3. Find the setting you'd like to change and edit the value as needed.

Example: To turn off automatic uploads, find this line: "LoadUploaderinApp":true
and change it to "LoadUploaderinApp":false.

4. Don’t forget to save the file when you're done.

Stop Capture from launching automatically

Windows

Option 1:

1. Open the Start menu and go to Settings > Apps > Startup.
2. Find Kaltura Capture in the list and toggle it off.

Option 2:

1. Open File Explorer.
2. Paste this path into the address bar (replace 'username' with your Windows user
name): C:\Users\user name\AppData\Roaming\Microsoft\Windows\Start
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Menu\Programs\Startup
3. If you see a Kaltura Capture shortcut there, right-click and choose Delete.

Mac

1. Go to System Preferences > Users & Groups.

2. Click the Login Items tab.

3. Select Kaltura Capture in the list and click the minus button (-) to remove it.

Alternative (both Windows and Mac)

You can also disable auto-launch through the settings file:

1. Open the Settings folder (see note at the top of this guide if you’'re not sure how).

2. Open the file called localSettings.json using a text editor like Notepad (right-click the
file and choose Open with > Notepad).

3. Look for this line: "silentStart": false and set it to "silentStart": true.

4. Save the file and close the editor.

Logging and diagnostics

Upload logs and get a Token ID

If Support asks you to send logs, you can do it from the app.
Try this:

Open Kaltura Capture.

Click Manage > Settings.

Click the Upload Logs button.

A message will appear with a Token ID - copy that ID and send it to Support.

W N

Need more detailed logs? If Support asks for advanced logs, see Increase log
level in Capture for step-by-step instructions.

Recording and input issues

Recording won't start

If you see the error "Failed to start recording. Please try again", it's often related to
your screen resolution or display scaling.
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Try this:

1. Lower your screen resolution to 1024x768
2. Set your display scaling to 100%
3. Restart Kaltura Capture and try again

Capture prerequisites and system requirements

Mac camera or microphone not working

If Capture can’t access your camera or mic, macOS may be blocking it due to privacy
settings.

Try this:

1. Go to System Preferences > Security & Privacy > Privacy.
2. In the left sidebar, click Camera and Microphone.
3. Make sure Kaltura Capture is checked in both.

On macOS Mojave and later, apps must request permission to access the built-in
FaceTime camera and microphone. If permission wasn’t granted when Capture was
first launched, you can enable it here. Learn more on Apple Support.

Capture doesn’t work over Remote Desktop

If you're using Capture through Remote Desktop (RDP) or Citrix, you might see errors
like:

e "Fail to load settings”

e "Failed to preview primary/secondary device"

Why this happens: Remote tools can’t provide direct access to your webcam, mic, or
screen so the app can’t function properly.

Fix: You’'ll need to run Capture directly on your local computer. It's not supported over
RDP.

Failed to load settings. Please contact
your administrator.
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Can’t record system audio (Mac)

macOS doesn’t allow apps to record system audio by default. This is a known limitation
and not something Capture can override.

Option: If you need to capture system audio on a Mac, talk to your CSM or Kaltura
Support to explore possible workarounds.

Admin and deployment

Get latest version for enterprise deployment

1. Check latest version in Kaltura Capture Release Notes

2. Copy the direct download link (e.qg.,
https://cdnapisec.kaltura.com/.../KalturaCapture_admin_4.x.x.msi) and provide it to

your IT team or whoever is responsible for software deployment at your
organization.

Use Procmon to monitor files and keys (advanced)

If you're troubleshooting a complex issue, you can use Microsoft Process Monitor
(Procmon) to see which files or registry keys Kaltura Capture is trying to access:

Download Microsoft Process Monitor.
Open Procmon64.exe
Go to Tools > Process Tree.

Find KalturaCapture.exe, right-click it, and select Add Process and children to
Include Filter.

W

If you're still having issues after trying the steps in this guide, contact your system
administrator or reach out to Kaltura Support.
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