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Kaltura Video Package for Moodle Installation
Guide

Last Modified on 07/27/2021 12:59 pm IDT

This document details the steps required to install the Kaltura Video Package 4.2.6 for Moodle 3.0 and later. If you are

upgrading from Kaltura Video Package 3.0, follow the instructions in the Kaltura Video Package 4.2.6 for Moodle 3.x
Upgrade Guide.

Prerequisites

e A Kaltura account:
o Partner ID (“pid”), e.g.,
o Admin secret, e.g.,

e A Kaltura Application Framework (KAF) instance URL, e.g., https://12345.kaf.kaltura.com
o Minimum Moodle version 3.x

Installation Background
e Local plug-in used to:

o Store configuration data and the Kaltura PHP client library (local/kaltura)
o Display the user's My Media repository (local/mymedia)

e Video assignment module, equivalent to the video assignment type for the Kaltura plug-in for Moodle 3.x

e Video resource module, equivalent to the video resource type for the Kaltura plug-in for Moodle 3.x
e Filter plug-in, used to display Kaltura video embed inside rich-text markups

Installation Process

i= To install the Kaltura Video Package 4.2.6

1. Download the latest Kaltura Video Package to your Moodle root directory fromhere
(https://moodle.org/plugins/pluginversions.php?id=447).
2. Unzip the Kaltura Video Package.

3. Browse to the Moodle home screen and click Continue to install the Kaltura Video Package

Installation - Moodle 2.6.2 (Build: 20140310)

Moodle 2.6.2 (Build: 20140310)
For iformation about this vesion of Moodle, pleass ses the oniine Relsase Notos.

Server checks
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Installation is processed. When finished, the Continue button is displayed.

Copyright © 2019 Kaltura Inc. All Rights Reserved. Designated trademarks and brands are the property of their respective owners. Use of this document
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4. Fill in the relevant information and click Continue.

Installation

New settings - Front page settings
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New settings - Manage authentication

sed selfregistration,is selected, then it enables potential users to register themseNves and create accounts. This results n the possiblty of spammers crealing accounts in order 1o use forum posts, blog enties etc. for spam. To avoid this rsk:

1fan authentication plugin, such
e disabl 4

Save chang

5. Click 'Save changes'.

6. Enter the Kaltura credentials (or verify that they were entered correctly) by going to the "Site Administration" area.
Then go to the "Plugins" tab. Next, scroll down to the "Local plugins" section. Click "Kaltura package libraries".
Enter the following information:

a. KAF URI: It should have the format [Instance ID]-kaf.kaltura.com. For example, 12345 .kaf.kaltura.com. NOTE:
Do not include an ending "/".

b. Server URI: By default this should be www.kaltura.com . For most use cases, this should not need to change.

c. Partner id: This is your Kaltura account number also referred to as a Partner ID (PID). The PID can be found
on the Integration Settings page of the Kaltura Management Console
(https:/kmc.kaltura.com/index.php/kmcng/settings/integrationSettings). For more information, see Integration Settings
(https://knowledge.kaltura.com/help/integration-settings).

d. Admin secret: This is an alphanumeric string used for integrations. The admin secret can be found on the
Integration Settings page of the Kaltura Management Console. For more information, see Integration Settings
(https://knowledge.kaltura.com/help/integration-settings).

e. Enable trace logging: Checked

When finished, the Kaltura Package Libraries page should look similar to the following:

Copyright © 2019 Kaltura Inc. All Rights Reserved. Designated trademarks and brands are the property of their respective owners. Use of this document
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Kaltura package libraries

KAF configuration

hitp://1688742-4 kaf kaltura.com/admin

KAF URI 1688742-4 kaf kaltura.com

local_kaltura | kaf_uri

Default: Empty
Type in the server URI of your KAF instance.

Server URI
local_kaltura | uri

www. kaltura.com

Default: www Kaltura.com

Type in the server URI you want to connect to. Otherwise just type in the
default settings (This setting is used for migration purposes).

Partner id 1688742
local_kaltura | pariner_id

Default: Empty
Enter the partner id for your account.

Admin secret
local_kaltura | adminsecret

Default: Empty
Enter the admin secret for your account.

Enable trace logging ¥ Default: No
local_kaltura |
Enable_loadnd \f enabled. all requests and responses 1o and from Kaltura are logged.
These logs can be used by Kaltura support to diagnose any problems
encountered. Enabling this setting may affect Moodle performance. You

may download a CSV file of the logs from here.

Set up the Filter Plugin
i= To set up the filter plug in

1. After the installation is complete, navigate to Plug-ins > Filters > Manage Filters. Enable the Kaltura Media filter
and click the Settings link.
2. Ensure that Embed Kaltura Video Links is checked. If not, check it.

Home » Site administration » Plugins » Filters » Kaltura Media

Kaltura Media

Embed Kaltura Video Links ¥ Default: Yes

filter_kaltura_enable . .
- - Convert Kaltura video links to embed code

3. Click Save.

Copyright © 2019 Kaltura Inc. All Rights Reserved. Designated trademarks and brands are the property of their respective owners. Use of this document
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Adding the Atto Text Editor
£= To add the Kaltura embed button to the Atto text editor (Moodle 3.x)

1. Login as administrator.
2. Go to Site administration > Plugins > Text editors > Atto HTML editor > Atto toolbar settings.
3. Under Toolbar config, add “kalturamedia’to any of the button groups. For example:

Toolbar config | files = image, media, managefileF. kalturamedia -
editor_atto | toolbar style2 = underline, strike, subschpr

align = align

indent = indent

insert = equation, charmap, table, clear

undo = undo

accessibility = accessibilitychecker, accessibilityhelper
other = html

L |

The “Embed Kaltura Video” is added to the Atto editor.

Description

we [B1][=iE]e|w|[m 8 o
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My Media
No setup is required for My Media. Users can find the link to My Media under the My Home menu.
= To move the My Media button

1. Login as administrator.
2. Go to Site administration > Appearance > Navigation.
3. Select Site under "Default home page for users".

Copyright © 2019 Kaltura Inc. All Rights Reserved. Designated trademarks and brands are the property of their respective owners. Use of this document
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MoodleCT

Moodle Customer Training

Dashboard » Site administration » Appearance » Navigation

NAVIGATION BE NaVigatIOh
Dashboard
b Site home Default home pade for users | Site v | Defduit Dashboard
b Site pages aefgitnomepage —
This determines the hop#é page for logged in users
~ My courses
» TC
y o Allow guest access to Dashboard  #  Default: Yes
allowguestmymoodle  |f enabled guests can access Dashboard, otherwise gues
b Courses
Show course fullnames [J  Default: No
navshowfullcoursenames  |f enabled, course full names will be used in the navigatio
ADMINISTRATION BE
w Site administration Show course categories #  Defaul: Yes
# Notifications navshoweategories  Show course categories in the navigation bar and navigat
£ Registration under mycourses without categories.

¥ Advanced features

Show my course categories [ Default: No

b Users

navshowmycoursecategories  |f enabled courses in the users my courses branch will be
b Courses
b Grades i

Show all courses @ Default: No

» Competencies navshowallcourses  ThiS Setting determines whether users who are enrolled it
) Badges courses in which they are enrolied)
b Location
F Language Sort my courses | Sort order v | Default Sort order
} Plugins navsortmycoursessort
) Security This determines whether courses are listed under My cou

and categories) or alphabetically by course setting.
¥ Appearance

b Themes

Course limit 20 Default: 20
&t Logos
alendar imits the number of courses shown to the user when the
Calend Limits th ber of Il 1o the hen th
## Blog
£+ Navigation Use site name for site pages [0 Default No

4. Click Save changes.

Boost Theme Support

The Boost theme may not have the ‘Navigation’ tab. The Kaltura Media Gallery will be available in other locations.

You can determine where to place the Kaltura Media Gallery link. The link may be in one of the following locations:

o Navigation Block
e Course setting menu

£= To add the link to Kaltura Media Gallery

1. Login as administrator.

2. Go to Site administration > Plugins > Local Plugins and select Kaltura Media Gallery.

Drshomns
Moodle 3.3
st ome
Dstnoat /S acmiliaion / Pl Local plugs | Kl s Gy Blocks ditingon
s
-
oy Kaltura Media Gallery ADMINEOOKMARCY
e tes ik Em——
Wy coures

Lk lozatan
RS —

TetCaurss
x o whnrs moctagatey Ik s clspiyod

‘S administration Seva changes.

3. Select where you want the Kaltura Media Gallery link to display.

Navigation Block

Copyright © 2019 Kaltura Inc. All Rights Reserved. Designated trademarks and brands are the property of their respective owners. Use of this document
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Select Navigation block for the link to appear on the left Navigation block.

moodle3.3vs4.0.12

Video Course

Video Course

Participants
Dashboard / My courses / Video Course

Badges
Competencies

Grades -
%5 Announcements

I General
W Topic Topic 1
W Topie2 E assignmentt
W Topic3
M Topic4 TOpiC 2
Kaltura Media Gallery

Topic 3

Course setting menu

User -

Your progress @

Select Couse settings for the link to appear on the course Admin settings menu:

= moodle3.3vs4.0.12

Video Course

Video Course

Participants
Dashboard / My courses / Video Course

Badges
Competencies
Grades —
l’Lel Announcements
W General

Topic 1

B Topicd

The default display is in the Navigation block.

Adding a Block

A ® User -

\\,;,-

;¢ Kaltura Media Gallery

Your progress

If you have permissions to add blocks to a course, you can add the Kaltura Media Gallery Block. The link to the Kaltura

Media Gallery will be added to the course side pane.

To add the Kaltura Media Gallery block

. Navigate to the site administration.
. Click Blocks editing on.

N =

moodle3.3vs4.0.12

Dashboard / Site administration / Search

Site administration

Site administration Users Courses Grades Plugins Appearance

3. Navigate to a course, and locate the Add a block button.

Server

\ Blocks editing on

Reports Development

Copyright © 2019 Kaltura Inc. All Rights Reserved. Designated trademarks and brands are the property of their respective owners. Use of this document
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course |

¢+ Topic 1
+ resour

Site administration

Add a block

4. Under the list of blocks, choose the Kaltura Media Gallery.

Add a block

Activities

Activity results
Admin bookmarks
Administration
Blog menu

Blog tags
Calendar
Comments

Community finder

Copyright © 2019 Kaltura Inc. All Rights Reserved. Designated trademarks and brands are the property of their respective owners. Use of this document
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Course/site summary
Feedback

Global search

HTML

Kaltura Media Gallery
Latest announcements
Latest badges

The results after adding the Kaltura Media Gallery block are as follows:

Dashboard / My courses / course22

Your progress KALTURA MEDIA GALLERY

LE] Announcements Kaltura Media Gallery
Tanir 1
Roles - Setting Permissions
This section provides information on how to set roles and permissions for users to use the Kaltura features.

The following provides steps on how to set up Kaltura permissions for each of the Moodle roles.

£= To Define Roles

1. Log in as Moodle admin
2. Go to Site Administration > Users > Permissions > Define Roles.

Copyright © 2019 Kaltura Inc. All Rights Reserved. Designated trademarks and brands are the property of their respective owners. Use of this document
constitutes acceptance of the Kaltura Terms of Use and Privacy Policy.
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Site administration

Site administration Users Courses Grades Plugins Appearance Server Reports Development
Users
Accounts Browse list of users

Bulk user actions

Add a new user

User default preferences
User profile fields
Conhorts

Upload users

Upload user pictures

Permissions User policies
Site administrators

Define roles

Assign system roles

Check system permissions
Capability overview

Assign user roles to cohort
Unsupported role assignments

A list all of the standard roles and all custom roles is displayed.

= To edit the permissions for each role

1. Select the Manage roles tab.
2. For EACH role that should be able to use the Kaltura Video Extension for Moodle, select the Gear icon to edit the
role.

Dashboard / Site administration / Users / Permissions / Define roles

Manage roles Allow role assignments Allow role overrides Allow role switches

Role © Description Short name Edit

Manager lanagers can access course and modify them, they usually do not participate in courses. manager v oo
Course creator Course creators can create new courses coursecreator A 4 OG0
Teacher Teachers can do anything within a course, including changing the activities and grading students editingteacher LI - |
Non-editing teacher Non-editing teachers can teach in courses and grade students, but may not alter activities. teacher K K2 |
Student Students generally have fewer privileges within a course. student - |
Guest Guests have minimal privileges and usually can not enter text anywhere quest ~ 4B
Authenticated user All logged in users. user s~ v O
Authenticated user on frontpage All logged in users in the frontpage course. frontpage +~ B0

Add a new role

3. Scroll down the Edit page until you see the list of permissions (there are a many permissions).

4. Use CTRL+F to find the string “Kaltura” on the Edit page. There are a several permissions related to the Kaltura
extension.

5. Set the permissions to Allow for each string that contains Kaltura and Save.

The following lists the available features/permissions:

e Block: Kaltura Media Gallery
o Add a new Kaltura Media Gallery block to Dashboard
e Kaltura package libraries (recommended for admins only)

Copyright © 2019 Kaltura Inc. All Rights Reserved. Designated trademarks and brands are the property of their respective owners. Use of this document
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o Download Kaltura trace logs
o Migrate Kaltura Data

Kaltura Media Gallery

o View Kaltura Media Gallery
Activity: Kaltura Media Assignment

o Add a Kaltura Media Assignment
Activity: Kaltura Video Resource

o Add a Kaltura Video Resource
Activity: Kaltura Media Assignment

o Grade video submissions
o Submit videos

Block: Kaltura Media Gallery

o Add a new Kaltura Media Gallery block
My Media

o View My Media page

e g e
View report
gradereport/singleview view
Grade report: User report
View your own grade report
gradereportiuser:view

Kaltura Media Gallery
View Kaltura Media Gallery
localkallur@mediagallery view
Activity: Assignment

Add a new assignment
mod/assign:addinstance
Activity: Assignment 2.2 (Disabled)
Add a new assignment
mod/assignmentaddinstance
Activity: Book

Add a new book

mod/book addinstance
Activity: Chat

Add a new chat
mod/chat:addinstance

= Allow (1]
1« Allow 1]
1« Allow

O Allow A

) Allow A

[ Allow A

O Allow A

Kaltura Video Quiz Moodle Gradebook Integration Deployment Guide

To complete your Kaltura deployment, please refer to Kaltura Video Quiz Moodle Gradebook Integration Deployment

Guide (https://knowledge kaltura.com/help/moodle-admin-config-kaltura-video-quiz-moodle-gradebook-integration-deployment-guide).
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